Shake at speed - Hyundai Elantra GT Turbo & Elantra GT N Performance Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 12-16-2019, 09:10 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 11
Shake at speed

Any one else have a shake at speed as if you have an off balance wheel ? Mine is only at 5000km and it drives shakes pretty good at higher speeds. Feels like its coming from my front drivers side wheel. Thought maybe it was the tires but put a brand new set of xice tires on steels hub centric and still produces the same shake at speeds. 2019 gt ntype is what I have.
Deathjam4 is offline  
post #2 of 4 (permalink) Old 12-17-2019, 06:48 PM
Member
 
CalculonsTalent's Avatar
 
Join Date: Oct 2019
Location: Boston (suburbs), MA
Posts: 72
Garage
Strange. I never had an issue before I out my xice tires on, and now I have a small shake at speed. I bought them used so I just assumed they weren't balanced (I asked the shop to check but they forgot to).

Quote:
Originally Posted by Deathjam4 View Post
Any one else have a shake at speed as if you have an off balance wheel ? Mine is only at 5000km and it drives shakes pretty good at higher speeds. Feels like its coming from my front drivers side wheel. Thought maybe it was the tires but put a brand new set of xice tires on steels hub centric and still produces the same shake at speeds. 2019 gt ntype is what I have.
CalculonsTalent is offline  
post #3 of 4 (permalink) Old 12-18-2019, 11:19 AM
Senior Member
 
miluardo's Avatar
 
Join Date: Aug 2019
Location: Toronto
Posts: 101
Garage
Quote:
Originally Posted by CalculonsTalent View Post
Strange. I never had an issue before I out my xice tires on, and now I have a small shake at speed. I bought them used so I just assumed they weren't balanced (I asked the shop to check but they forgot to).
I've got no shake, even at speeds of 140/150km/h with 17inch steelies and Falken HS449s.

Shake and heavy vibration COULD be the tire -- but could also be loose bolts, and many other things.
miluardo is online now  
post #4 of 4 (permalink) Old 12-18-2019, 10:07 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 11
Eliminated brakes tires and rims. Had 4 new rims installed hub centric this time still have vibration in the front. I told them to align the car but they were like " oh yeah the new rims will defantly get you going straight no shakes. "

Sure it helped a tiny bit but still shakes lol I told um that now they have to take it back in. I might ask for a partial refund as well on the rims i shouldn't have had to replace.
Deathjam4 is offline  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome