Hyundai Elantra GT banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Any one else have a shake at speed as if you have an off balance wheel ? Mine is only at 5000km and it drives shakes pretty good at higher speeds. Feels like its coming from my front drivers side wheel. Thought maybe it was the tires but put a brand new set of xice tires on steels hub centric and still produces the same shake at speeds. 2019 gt ntype is what I have.
 

·
Registered
Joined
·
72 Posts
Strange. I never had an issue before I out my xice tires on, and now I have a small shake at speed. I bought them used so I just assumed they weren't balanced (I asked the shop to check but they forgot to).

Any one else have a shake at speed as if you have an off balance wheel ? Mine is only at 5000km and it drives shakes pretty good at higher speeds. Feels like its coming from my front drivers side wheel. Thought maybe it was the tires but put a brand new set of xice tires on steels hub centric and still produces the same shake at speeds. 2019 gt ntype is what I have.
 

·
Registered
Joined
·
125 Posts
Strange. I never had an issue before I out my xice tires on, and now I have a small shake at speed. I bought them used so I just assumed they weren't balanced (I asked the shop to check but they forgot to).
I've got no shake, even at speeds of 140/150km/h with 17inch steelies and Falken HS449s.

Shake and heavy vibration COULD be the tire -- but could also be loose bolts, and many other things.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
Eliminated brakes tires and rims. Had 4 new rims installed hub centric this time still have vibration in the front. I told them to align the car but they were like " oh yeah the new rims will defantly get you going straight no shakes. "

Sure it helped a tiny bit but still shakes lol I told um that now they have to take it back in. I might ask for a partial refund as well on the rims i shouldn't have had to replace.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
So recent update on my shake. Took the brakes apart meself cause screw the dealer focusing on my tires all the time. So my brake pads had a crap ton of grease on the sliders which got full of road debris and locked my pads against the rotors. I was getting horrible mileage cause of this. I also on a bonus found out my rear brake caliper on the passenger side was leaking brake fluid out of the cylinder ... this resulted in a spongy brake peddle of which I complained about multiple times.

I freed my pads which took me over 2 hrs to do cleaned them a bit and now my vibrations are almost gone. I just have something going on with the one rear brake rubbing at one spot meaning my rotor has warped. At the dealership now to have that caliper replaced cause feck having no brakes that's a disaster waiting to happen. Never did check my drivers side rear but I am hoping it's not the same.
 

·
Registered
Joined
·
125 Posts
So recent update on my shake. Took the brakes apart meself cause screw the dealer focusing on my tires all the time. So my brake pads had a crap ton of grease on the sliders which got full of road debris and locked my pads against the rotors. I was getting horrible mileage cause of this. I also on a bonus found out my rear brake caliper on the passenger side was leaking brake fluid out of the cylinder ... this resulted in a spongy brake peddle of which I complained about multiple times.

I freed my pads which took me over 2 hrs to do cleaned them a bit and now my vibrations are almost gone. I just have something going on with the one rear brake rubbing at one spot meaning my rotor has warped. At the dealership now to have that caliper replaced cause feck having no brakes that's a disaster waiting to happen. Never did check my drivers side rear but I am hoping it's not the same.
Wow, and you bought this car brand new?

Do you think this is a manufacturer defect, or was this a maintenance mistake/driving habit type thing?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
I think this was more a factory issue and a couple defective seals. Most of the other stuff is just cheap parts. Stuff is going down hill these days cause it's all about how to make more and give us less. I'll be checking them shortly and see if they are still leaking. They tried telling me it was grease on the boot and piston... looked like a leak to me since it was all leaking downwards and on the bottom of the caliper. I got a print out of he parts and it's not rocket science.

It's a dust seal a piston and a secondary rubber ring seal. They tho are trying to tell me the dust seal keeps the liquid in but actually it's supposed to be the rubber ring at the back of the piston. The dust seal is only literally to keep dust out only. I think it may be the electronic part of the brake it may be shoving the piston to hard. It's all speculation tho till I can prove it.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
So after they cleaned "" my brakes one hard brake a day later I am left with 25% braking power. Think I'll be contacting the main canadian office about it cause my car is unsafe. And i think my vibration is my front drivers axle. I think day one the axel snapped a splint off inside and i have a rouge ball popping in and out. I say this cause my vibrations can get bad to worse to nearly gone.
 
1 - 8 of 8 Posts
Top