Hyundai Elantra GT banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
X-posted - 2019 N-line DCT with 1100 miles... I was pulling out of a parking lot tonight onto a busy highway. I was not in Sport mode, but gunned it. It took off like normal to about 30mph and then made a pop (like a back fire, but upfront) and lost power. I barely made it across the road to another parking lot. I shut it off for a few seconds and started it back up. I pulled back out onto the highway and it had all the normal power. I tested it a few more times driving home & all seemed well. I did just install a K&N replacement filter. Any ideas?
 

·
Registered
Joined
·
69 Posts
My first guess was that an intake pipe between the intake and turbo came free. The pop would be the pipe/hose coming off and the pressure releasing. It would explain both the pop and the loss in power (no boost pressure). Since you say you now have normal boost power it's hard to say.


If you find out what it was let us know!
 

·
Registered
Joined
·
244 Posts
My first guess was that an intake pipe between the intake and turbo came free. The pop would be the pipe/hose coming off and the pressure releasing. It would explain both the pop and the loss in power (no boost pressure). Since you say you now have normal boost power it's hard to say.


If you find out what it was let us know!
That sounds most likely. Coming from other communities, this was one of the more common culprits.
 
1 - 3 of 3 Posts
Top